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1 Configuration of the CIF50-PB interface

When you receive a CIF50-PB card, this card is blank. That means it has no specific configuration
but only the Profibus firmware is loaded. For the configuration of the project-specific settings like bus
parameters, connections and FMS objects, the so-called SyCon software is required. SyCon requires
a license from the company Hilscher. It is a customer related license, so it can be used on multiple
systems of the license owner.

Note: In a second step the HFB OPC Server has to be configured with the so-called HFB
Power Tool. Since the CIF50-PB card resp. the CIF device driver is not able to
communicate with two programs at the same time, you have to make sure, that only
one of the two programs (SyCon or HFB Power Toll) is active (at the same time).
Otherwise especially the Online functions of the SyCon (Download, Live List, FMS
Monitor etc.) and the HFB Power Tool will not work properly and can lead to a
undetermined system state.

1.1 Starting SYCON

Picture 1: Start of SYCON via Windows Start Menu

Start->All Programs->SyCon System Configuration->SyCon
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1.2 Create a new configuration

Picture 2: SYCON: Create new configuration 

Select File->New from the Sycon application menu to create a new (blank) configuration.
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1.3 Add a CIF50-PB as Profibus Master device to the new configuration

Picture 3: Insert a Master Device. 

Klick the Insert Master Button. 

Move the special M-Cursor to the top row of the configuration window and click left mouse
button. The selection dialog with a list of the available master devices occurs. 

Select CIF50-PB from the list of Available masters and...

... click the Add button to move it to the Selected master list.

Set the Profibus station address for the CIF50-PB master. This address must be the same as
specified in the field Remote PROFIBUS address of the communication reference in the
Step7 NetPro software! See the following screen shot for an example:
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Give the Master CIF card a meaningful name. Note: Special characters like ‘-‘ (minus),’ _’
(underline) or ‘ ’ (space) are not allowed in the description text!

Click OK button to close the dialog and to add the CIF50-PB device to the configuration
window.

Picture 4: Device Assignment Question Dialog Box. 

If a CIF50-PB card is installed in the system and this card isn’t assigned to another (opened)
SyCon configuration, this Question Dialog Box occurs. Click the Yes button to assign the
CIF50-PB card to the Master device of your new configuration.
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1.4 Check the Device Driver and Board assignment 

Picture 5: Opening the Device Assignment dialog. 

You can verify the current board assignment by selecting the menu item Settings->Device
Assignment... from the Sycon application menu.

Picture 6: Device driver info and Board Selection dialog. 

When the CIF50-PB board and the device driver software are installed correctly, the board
should be displayed as Board 0 and should be assigned to the new configuration.
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1.5 Set the Profibus Bus Parameters

Picture 7: Opening the Bus Parameter Dialog. 

Select Settings->Bus Parameters... to open the Bus Parameter dialog.

Picture 8: Bus Parameter Base Dialog. 

Select the proper baud rate in the Baud rate drop down list. 

To be able to set individual Profibus bus parameters, you have to select By User in the
Optimize  drop down list. This selection enables the Edit... button.

Click the Edit... button to open the Profibus parameters dialog.
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The following screen shots show the relation of the bus parameters between the CP343-5 Bus
Parameter Dialog in Step7  and the SyCon Bus Parameter Dialog. 

Picture 9: Relation between SyCon Bus Parameters and CP343-5 Bus parameters. 

Make sure, that all parameters in the SyCon dialog are set to the same value as in the CP343-5 Bus
Parameter dialog.



Application note 

HFB Driver / OPC Server: Connecting to a S7 PLC via Profibus FMS Page 11

1.6 Create a Communication Reference

Picture 10: Opening the Communication Reference List dialog. 

Select Settings->Communication Reference List(CRL).... to open the CRL dialog.

Picture 11: Expanding the Communication Reference List dialog. 

Click the More Details >> button to expand the CRL dialog.

Picture 12: Creating a new communication reference and station. 

To add a new Profibus device (e.g. a S5 PLC with CP5431), click the New CRL new station
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address button. The new device will automatically be added to the configuration window after
the new communication reference is completely defined.

Picture 13: Comm. Ref. Device selection. 

Select “—/ Other device” from the Remote address/device list.

Picture 14: Comm. Ref.: Remote address of new device. 
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Enter the Profibus station address of the new remote device. This address must correspond
to the Local PROFIBUS address in the NetPro FMS Connection Options settings.

Enter a meaningful name for the new PLC device.

Click the OK button to close the dialog.

Picture 15: Relation of SAPs, LLI Timer and Max. PDU between  NetPro FMS Connection Options and SyCon.  

Enter the Local SAP value which corresponds to the Remote LSAP value in the NetPro.

Enter the Remote SAP value which corresponds to the Local LSAP value in the NetPro.

Enter the LLI-Timer value which corresponds to the Monitoring interval value in the NetPro.

Verify and if unequal enter the Max. PDU Size value which corresponds to the Max. PDU
length value in the NetPro.
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Enter the SCC and RCC values according to the Max. SCC and Max. RCC values in the
NetPro.

Click the OK button to terminate the configuration of the communication reference.
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1.7 Create an Object for test purposes

Basically it is not necessary to configure all of the FMS data objects which are configured in the
remote stations (PLCs) but to test the communication between SyCon and the remote PLC it is
necessary to configure at least one FMS object. 

1.7.1 Pick one object from the list of configured objects in the PLC

Picture 16: Select a FMS Object in Step7 Symbol Editor 

Open the Step7 Symbol Editor.

Select a symbol of a FMS object. Symbols of a FMS objects are marked with a green flag icon.

Open the context menu and select sub menu item Special Object Properties-
>Communication.
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Picture 17: FMS Object definition in Step7 Symbol Editor 

The Communication properties dialog shows all information about the FMS object.

Select the Structure tab.  The field FMS index  shows the FMS object index, the column

FMS type   shows the data type of the FMS object.

Scroll down to the bottom of the list to find out the size (highest sub index) of the FMS object.

1.7.2 Configure the FMS object in SyCon

Picture 18: Opening FMS Object Directory dialog in SYCON.
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Before you open the Object Directory dialog you must select the remote station (PLC),
because the FMS object are logically owned by the remote stations but not by the CIF50 card.
So all object have to be configured in the context of its owner which is the PLC.

Select Settings->Object Directory(OD).... to open the object directory dialog.

Picture 19: Relation of FMS Object parameters between SyCon and Step7 FMS Symbol.  

Enter the Object index which corresponds to the FMS Index value of the object in the Step7
Symbol Editor Communication Properties dialog.

Enter a meaningful name for the object.
.

Select Object type Array and enter the array’s number of elements which must correspond
to the FMS subindex value on the bottom line of the variable list in  Step7 Symbol Editor
Communication Properties dialog.
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Set the data type, corresponding to the value in the FMS type column of the object variable list
in  Step7 Symbol Editor Communication Properties dialog.

 
Click the OK button to terminate the configuration of the object.

1.8 Save the configuration

Picture 20: Saving the configuration.  

Select File->Save As.... to open the File Save dialog.

Picture 21: SyCon File save dialog.  

Enter a meaningful name for the configuration file. File extension must be named to ”.pb”.

Click the Save button to store the configuration to the file.
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1.9 Download the configuration

Before the CIF50-PB card can work with the new configuration, the configuration has to be
downloaded to the CIF50-PB card into a non-volatile (permanent) flash memory. 

Picture 22: Downloading the configuration.  

Select Online->Download... to open the Download dialog.

Picture 23: Download question.  

Click Yes.

Picture 24: Download in progress.  

After the download is finished, the Error field should show error 0.
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1.10 Check Live List of Profibus stations

Picture 25: Opening Live list.  

Select Online->Live List... to open the Live List dialog.

Picture 26: The SyCon Live list.  

Assumed that the Profibus parameters are set correctly, both devices are connected via Profibus
cable and the PLC is switched on, the two configured devices 2 (  the the PC station with the

CIF50-PB card) and 11 (  the PLC) must be displayed with green background color.

If only the PC station is marked green, you should check 
1. The Profibus parameters on both sides
2. The Profibus cable (especially the termination).
3. Run/Stop state of the S7-CP343-5
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1.11 Check FMS connection 

To verify if the FMS communication reference is configured properly you can try to read the FMS
object which was previously configured in step 1.7.2.

Picture 27: Opening the FMS Monitor.  

Select Online->FMS Monitor... to open the FMS Monitor dialog.

Picture 28: The FMS Monitor which shows object’s data values.  

Select the communication reference (CR) to the PLC. If only one CR is configured, this CR is
already  selected.

Select the FMS object you want to read from the PLC. If only one object is configured, this
object is already  selected.
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Click the Send button. The CIF50-PB card then tries to open the connection via the selected
communication reference. If the connection can be established, the program reads the object
data from the PLC.

If the object could be read successfully, all data values of the object are listed in the Value list.
If the connection could not be established or the object couldn’t be read, the Value list shows
detailed error information. The following screen shot shows such an error message:

Picture 29: The FMS Monitor which shows connection error.  

The variety of possible errors is very high and we can’t describe all these errors and reasons for it
here in this manual. You can find a description of these errors in the Hilscher Protocol interface
manual for Profibus FMS which you can download via the following link:
www.incosol.de/WP_Downloads/Hilscher_PIM_Profibus_FMS_EN.pdf

See chapter 3.2 General Error Messages (page 14 and following) for details about errors and its
reasons.

If you have successfully passed all the steps up to this point you can save the SyCon configuration,
 close the SyCon software and continue with the next main step, the configuration of the HFB Driver
/ OPC Server.
As mentioned at the beginning of the chapter, it is mandatory to close the SyCon software before the
HFB software is started and vice versa. The HFB process HFBDRV.EXE may not be started together
with the SYCON.EXE process. Please be aware of this circumstance!

http://www.incosol.de/WP_Downloads/Hilscher_PIM_Profibus_FMS_EN.pdf
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2 Configuration via HFB Power Tool

2.1 Start the HFB Power Tool

Picture 30: Starting HFB Power Tool via Windows Start Menu

You can start the HFB Power Tool via Windows Start Menu.
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2.2 Create a new configuration

Picture 31: Opening the program’s backstage menu

Click on the HFB Program Icon to open the application (backstage) menu.

Picture 32: Creating a new (blank) configuration.

Select the menu item New to create a new (blank) configuration.
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2.3 Create a new channel

Picture 33: Creating  a new channel

Select the root item HFB (Online) in the Object Tree View, open the context menu via right
mouse click and select Add Channel form the context menu to create a new channel object.

2.4 Configure the new channel

Picture 34: Configuring the new channel, part 1.

Give the channel an unique name. This name must not be used for another channel!
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Since the new channel not  yet has a specific communication way, you have to select the
proper communication way Profibus FMS via CIF50-PB from the Communication Way drop
down list. The program then automatically loads the specific dialog for the selected
communication way.

2.4.1 Configure the specific channel parameters

Picture 35: Configuring the specific channel parameters.

Select the entry CIF 0 from the CIF Board drop down list. 

Click the radio button S7M comp in the I/O Address Syntax group. This setting is very
important because it controls the syntax of the iFIX I/O address resp. the OPC Item ID.

Enable the channel.
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2.5 Create a new device

Picture 36: Creating  a new device

Select the previously created channel in the Object Tree View, open the context menu via right
mouse click and select Add Device from the context menu to create a new device object.

2.6 Configure the new device

Picture 37: Configuring the specific device parameters.
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Give the device an unique name. This name must not be used for another device! 

Note! The device name will later on be used as part of an iFIX I/O address or an OPC item id.

Enter the FMS communication reference index. This index corresponds to the communication
reference (CR) number which is automatically generated by the SyCon software when a new
CR is created (see chapter 1.6). You can determine this index as shown in the following
screen shot of the SyCon Communication Reference List dialog:

Picture 38: Determine the Communication Reference Index

Enable the device.

2.7 Create a new data block

Picture 39: Creating  a new data block
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2.8 Configure the new data block

Picture 40: Relation of parameter between data block and  Step7 FMS Variable  

Give the data block an unique name. This name must not be used for another data block!

Enter the object index according to the FMS index value in the Step7 Symbol Editor
Communication Properties dialog.

Set the data type, corresponding to the value in the FMS type column of the object variable list
in  Step7 Symbol Editor Communication Properties dialog.

Enter the Length (number of array elements) of the FMS object which must correspond to the
FMS subindex value on the bottom line of the variable list in  Step7 Symbol Editor
Communication Properties dialog.

Set the Byte Order to LB-HB. This is the proper setting for a S7 FMS connection. Connection
to other PLCs than S7 might require opposite byte order setting.

Enable the data block.

Now a minimum configuration is completed. Of course you can add additional channels, devices and
data blocks as required for your application.
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All parameters for channel, device and data block which are not described in this documentation can
be left at their default values. The only parameters which may have to be adapted are the polling
parameters (primary rate, secondary rate and access time) of the data block.

2.9 Save the new configuration

Picture 41: Opening the program’s backstage menu

Click the HFB Program Icon to reach the application (backstage) menu.

Picture 42: Saving the new configuration



Application note 

HFB Driver / OPC Server: Connecting to a S7 PLC via Profibus FMS Page 31

Select the menu item Save As... to open the File Save dialog.

Picture 43: Configuration file save dialog

Select a folder and enter a valid file name. The name must have the extension .HFB. 

Click the Save button to finally save the configuration to disk.

2.10 Set the new configuration as default/startup configuration 

Picture 44: Setting default configuration path and file

Open the application (backstage) menu and select the menu item Options.

Click the Default Paths button to open the Default paths and filenames dialog.

Enter the complete path of the previously saved configuration file.
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Enter the name of the previously saved configuration file.

Click the Save button to store the modified values permanently. 

2.11 Online check of the new configuration

Picture 45: From backstage view to configuration view

Click the Home tab to go back to the configuration view

Picture 46: Message sequence in Log Viewer window
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Check the program header for the correct configuration file path and name which you have
entered as default/startup configuration.
.
If the driver is not yet started, click the Start button to start it.

Check the messages in the Log Viewer window. For the previously configured channel and
device the following sequence of messages should appear:

Channel <Your channel name>: Comm. Thread FMS CIF started!  

Channel <Your channel name>: (Re)connect all devices! 

Channel <Your channel name>: Open of CIF Device Driver successful

Channel <Your channel name>: Initialization of CIF card successful.

If some of these messages are not shown but instead error messages then you should verify all
channel, device and data block parameters, you have configured before. If the problem should persist
please contact our support team at support@incosol.de and send us a screen shot of the Log Viewer
Window for further analysis.

Hint: For a better presentation of the messages in the Log Viewer window you can drag this window
out of the HFB Power Tool’s program frame. Afterwards you can resize the separated window in
height and width to display a larger amount of messages.

Picture 47: Dragging the Log Viewer window

To drag the window click into the header line of the Log Viewer window, keep the left mouse button
pressed and drag the window to the desired area of the desk top. Now you can resize the separated
window by pulling it with the mouse cursor at any edge or corner of the window.

mailto:support@incosol.de
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Picture 48: Separated Log Viewer Window

2.12 Check the communication state of a particular data block

Picture 49: Data block statistics

Click the expand button in the data block’s Statistics and Diagnostics Group to expand the
dialog. The expanded dialog now shows numerous data fields with counter values, timestamps
and other values which give you a detailed view of the runtime behaviour of the data block.

When the data block or the FMS object is polled properly, the counter fields R/W Requests
and R/W Responses should increase in the rate specified by the Primary Rate field.

The Last Error Class, Code and Text field should show 0 resp. No Error.
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3 Configuration of the Clients (iFIX or OPC)

The Item ID and iFIX I/O Address must follow the following structure:

For a digital address:
<Device Name>:OB.<FMS Object>.< Index>.<Bit Number>

For a analog address
<Device Name>:OB.<FMS Object>.< Index>|<Option>

<Device Name> Is the name of the HFB device as specified in chapter 2.6. A FMS
communication reference to a specific PLC is specified by this device name.

Picture 50: Device name is part of the I/O address

<FMS Object> Is the number of the FMS object. A data block must  be created in the HFB
configuration for this object number.

Picture 51: FMS Object number is part of the I/O address

<Index> Specifies a single data item within the FMS object. Minimum index is 1 (start
index of HFB data block) and the maximum index is the end index or the length
of the HFB data block.

Picture 52: FMS Index is part of the I/O address

<Option> are valid for analog addresses of particular data types. The following table
shows all possible options:
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Option allowed data types Description

LBYT Int16 Converts the lower 8 bits of a signed 16 bit value to a

signed 8 bit value

UInt16 Converts the lower 8 bits of an unsigned 16 bit value to an

unsigned 8 bit value

HBYT Int16 Converts the upper 8 bits of a signed 16 bit signed value to a

signed 8 bit value

UInt16 Converts the upper 8 bits of an unsigned 16 bit value to an

unsigned 8 bit value

LWRD Int16 Converts the lower 8 bits of a  (signed or unsigned) 16 bit value

(signed or unsigned) to an unsigned 8 bit value

HWRD Int16 Converts the upper 8 bits of a  (signed or unsigned) 16 bit value to

an unsigned 8 bit value

FWRD Int16 Converts a 16 bit signed value to an unsigned 16 bit value

FDIN* Int16 Converts * two consecutive 16 bit values to a signed 32 bit value

FDWR* Int16 Converts * two consecutive 16 bit values to an unsigned 32 bit value

FREA* Int16 Converts two consecutive 16 bit values to a 32 bit floating point

(real) value

* )The block write mode of the respective data blocks has to be set to “Auto” when values with these options

must be written.

Table 1: Possible signal conditioning options

<Bit Number> For an analog data item of an integer data type (Int8, UInt8, Int16 and UInt16) a
single bit can be addressed by extending an analog I/O address with the bit
number between 0 and 15.

3.1 Examples of OPC Item IDs

Picture 53: Example of OPC Items
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